]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
git-cache: 1.3.1 → 1.4.2
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 1b2c65f66545284feb21af06df8e1c44e9e17834..12751ec5737fd860b1e781294fd0d90d8356e6b8 100644 (file)
@@ -1,9 +1,40 @@
-self: super: {
-  pinch = super.writeShellScriptBin "pinch" ''
-    exec ${self.python3}/bin/python3 ${super.fetchgit {
-      url = "https://scottworley.com/pinch.git";
-      rev = "1.1";
-      sha256 = "0ilbhvr0d83kfwkm7ak64gik44gi2axfnp9rzsa7g5cwz9qaxdbv";
-    }}/pinch.py "$@"
-  '';
-}
+self: super:
+let
+
+  fallback-git-cache = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
+      buildPythonPackage rec {
+        pname = "git-cache";
+        version = "1.4.2";
+        src = fetchgit {
+          url = "https://git.scottworley.com/pub/git/git-cache";
+          rev = "v${version}";
+          hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
+        };
+        propagatedBuildInputs = [ backoff ];
+        checkInputs = [ git mypy ];
+        doCheck = true;
+        checkPhase = "./test.sh";
+      }) { };
+
+  fallback-pinch = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
+      buildPythonPackage rec {
+        pname = "pinch";
+        version = "3.0.9";
+        src = fetchgit {
+          url = "https://git.scottworley.com/pub/git/pinch";
+          rev = "v${version}";
+          sha256 = "sha256-D1XC8pmemdOpIEWvS0VH9Fguvp92FqpQfJj2TudfwRw=";
+        };
+        buildInputs = [ makeWrapper ];
+        propagatedBuildInputs = [ git-cache ];
+        checkInputs = [ nix_2_3 git mypy ];
+        postInstall = ''
+          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+        '';
+        doCheck = true;
+        checkPhase = "./test.sh";
+      }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
+
+in { pinch = super.pinch or fallback-pinch; }