]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - modules/auto-upgrade.nix
Remove the business-hours feature
[auto-upgrade-with-pinch] / modules / auto-upgrade.nix
index ef705eb8ad30176d93202f6c99f1504e93c013ef..c9a8905b564400484b0b51621704dab9a11cb7bb 100644 (file)
@@ -325,17 +325,6 @@ in {
         # intervene either to fix the problem or disable automatic updates.
         sleep 2h
 
-        # Wait until outside business hours
-        now=$(date +%s)
-        day_of_week=$(date +%u)
-        business_start=$(date -d  8:00 +%s)
-        business_end=$(  date -d 17:00 +%s)
-        if (( day_of_week <= 5 && now > business_start && now < business_end ));then
-          delay=$((business_end - now))
-          echo "Waiting $delay seconds so we don't upgrade during business hours" >&2
-          sleep "$delay"
-        fi
-
         ${auto-upgrade-script}
       '';