]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
pinch: 3.0.15 → 3.1.0 for "git_ref = tag <tag>" support
[auto-upgrade-with-pinch] / overlays / pinch.nix
index ddaed6f9389bab33747fbff9731ab2e579d0cb6b..37c2e7d079f7ea1816b53c59a815e09403f85c43 100644 (file)
@@ -1,14 +1,44 @@
-self: super: {
-  pinch = if builtins.hasAttr "pinch" super then
-    super.pinch
-  else
-    super.writeShellScriptBin "pinch" ''
-      exec ${self.python3}/bin/python3 ${
-        super.fetchgit {
-          url = "https://scottworley.com/pinch.git";
-          rev = "1.2";
-          sha256 = "0s0rk1m0irsdj0xjnix9y1825pjv7lhbmnn73jgjbj1hi6wqwpfh";
-        }
-      }/pinch.py "$@"
-    '';
-}
+self: super:
+let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+
+  fallback-git-cache = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
+      buildPythonPackage rec {
+        pname = "git-cache";
+        version = "1.5.0";
+        src = fetchgit {
+          url = "https://git.scottworley.com/pub/git/git-cache";
+          rev = "v${version}";
+          hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
+        };
+        propagatedBuildInputs = [ backoff ];
+        "${checkInputsName}" = [ git mypy ];
+        doCheck = true;
+        checkPhase = "./test.sh";
+      }) { };
+
+  fallback-pinch = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
+      buildPythonPackage rec {
+        pname = "pinch";
+        version = "3.1.0";
+        src = fetchgit {
+          url = "https://git.scottworley.com/pub/git/pinch";
+          rev = "v${version}";
+          hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
+        };
+        buildInputs = [ makeWrapper ];
+        propagatedBuildInputs = [ git-cache ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
+        postInstall = ''
+          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+        '';
+        doCheck = true;
+        checkPhase = "./test.sh";
+      }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
+
+in { pinch = super.pinch or fallback-pinch; }