# Update channels
(
cd /etc/nixos
- ${pkgs.keyedgit cfg.key}/bin/git pull --ff-only --verify-signatures
+ ${pkgs.keyedgit cfg.keys}/bin/git pull --ff-only --verify-signatures
${pkgs.pinch}/bin/pinch update channels
)
'';
};
- key = mkOption {
+ keys = mkOption {
type = types.path;
description = ''
- GPG key that signs updates. Updates are only merged if the commit
- at the tip of the remote branch is signed with this key.
+ File containing GPG keys that sign updates. Updates are only merged
+ if the commit at the tip of the remote branch is signed with one of
+ these keys.
'';
};