self: super:
let
+ checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
fallback-git-cache = self.python3Packages.callPackage
({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.3.1";
+ version = "1.5.0";
src = fetchgit {
url = "https://git.scottworley.com/pub/git/git-cache";
rev = "v${version}";
- sha256 = "0awz7f6avzw9fk9gp1kadj0nbmf1s60qic9zb6ww92zig3khg12k";
+ hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
};
propagatedBuildInputs = [ backoff ];
- checkInputs = [ git mypy ];
+ "${checkInputsName}" = [ git mypy ];
doCheck = true;
checkPhase = "./test.sh";
}) { };
({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
buildPythonPackage rec {
pname = "pinch";
- version = "3.0.9";
+ version = "3.1.0";
src = fetchgit {
url = "https://git.scottworley.com/pub/git/pinch";
rev = "v${version}";
- sha256 = "sha256-D1XC8pmemdOpIEWvS0VH9Fguvp92FqpQfJj2TudfwRw=";
+ hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
};
buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
- checkInputs = [ nix_2_3 git mypy ];
+ "${checkInputsName}" = [ nix_2_3 git mypy ];
postInstall = ''
wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
'';