]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
git-cache: 1.4.2 → 1.4.3
[auto-upgrade-with-pinch] / overlays / pinch.nix
index dfb9eaca3b737001867c477c22a10268a2ff1bd7..7dcddb06546f07b6f91b20c9723bb346b935ebbc 100644 (file)
@@ -1,18 +1,22 @@
 self: super:
 let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
         pname = "git-cache";
-        version = "1.4.2";
+        version = "1.4.3";
         src = fetchgit {
           url = "https://git.scottworley.com/pub/git/git-cache";
           rev = "v${version}";
-          hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
+          hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
         };
         propagatedBuildInputs = [ backoff ];
-        checkInputs = [ git mypy ];
+        "${checkInputsName}" = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
@@ -29,7 +33,7 @@ let
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        checkInputs = [ nix_2_3 git mypy ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
         postInstall = ''
           wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';