+
+ userEnvironment = {
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Whether to update a user-environment as well. This update is done
+ with nix-env -riA. Note the -r! I.e., ALL OTHER PACKAGES INSTALLED
+ WITH nix-env WILL BE DELETED!
+
+ This presumes that you have configured an "entire user environment"
+ package as shown in
+ https://nixos.wiki/wiki/FAQ#How_can_I_manage_software_with_nix-env_like_with_configuration.nix.3F
+
+ To check if you're set up for this, run "nix-env --query". If it
+ only lists one package, you're good to go.
+ '';
+ };
+
+ user = mkOption {
+ type = types.str;
+ description = ''
+ The username of the user whose environment should be updated.
+ '';
+ };
+
+ package = mkOption {
+ type = types.str;
+ example = "nixos.userPackages";
+ description = ''
+ The name of the single package that is the user's entire environment.
+ '';
+ };
+
+ };