}
}
- # Update channels
+ # Fetch updates
(
cd /etc/nixos
${pkgs.git}/bin/git fetch
PATH="${pkgs.keyedgit cfg.keys}/bin:$PATH" ${pkgs.polite-merge}/bin/polite-merge --ff-only --verify-signatures
- ${pkgs.pinch}/bin/pinch update channels
)
+ # Update channels
+ ${pkgs.pinch}/bin/pinch update /etc/nixos/channels
+
# Build
in_tmpdir ${config.system.build.nixos-rebuild}/bin/nixos-rebuild build
as_user nix-build --no-out-link '<nixpkgs>' -A ${