]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/polite-merge.nix
Drop 22.11 support: Just use "nativeCheckInputs"
[auto-upgrade-with-pinch] / overlays / polite-merge.nix
index 87abfd74e788e0d4b130138495bf41d88ffb8aae..c4a02a81ad3094c2b753b193cab679eda58fbebb 100644 (file)
@@ -5,14 +5,14 @@ self: super: {
     self.callPackage ({ fetchgit, git, stdenv, }:
       stdenv.mkDerivation rec {
         pname = "polite-merge";
-        version = "2.3";
+        version = "2.4";
         src = fetchgit {
-          url = "https://scottworley.com/polite-merge.git";
+          url = "https://git.scottworley.com/pub/git/polite-merge";
           rev = version;
-          sha256 = "0777h8pyvpml91w7lkj41shb16vpk2sbazlng44488zk3i8alq18";
+          sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
         };
         postUnpack = "patchShebangs .";
-        checkInputs = [ git ];
+        nativeCheckInputs = [ git ];
         doCheck = true;
         preInstall = "export prefix";
       }) { };