self.callPackage ({ fetchgit, git, stdenv, }:
stdenv.mkDerivation rec {
pname = "polite-merge";
- version = "2.3";
+ version = "2.4.1";
src = fetchgit {
- url = "https://scottworley.com/polite-merge.git";
- rev = version;
- sha256 = "0777h8pyvpml91w7lkj41shb16vpk2sbazlng44488zk3i8alq18";
+ url = "https://git.scottworley.com/pub/git/polite-merge";
+ rev = "v${version}";
+ hash = "sha256-WtxDKKc3/IkLahVnrbfBXj6DoX1Rbu0qrIZK7D4Z7hY=";
};
postUnpack = "patchShebangs .";
- checkInputs = [ git ];
+ nativeCheckInputs = [ git ];
doCheck = true;
preInstall = "export prefix";
}) { };