]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
polite-merge: 2.0 -> 2.1
[auto-upgrade-with-pinch] / overlays / pinch.nix
index d85be2d49e17741bce7616f4db98062c35570773..29d229385d9f48ae2f530e4cd768a7d9b4e21869 100644 (file)
@@ -1,9 +1,14 @@
 self: super: {
-  pinch = super.writeShellScriptBin "pinch" ''
-    exec ${self.python3}/bin/python3 ${super.fetchgit {
-      url = "https://scottworley.com/pinch.git";
-      rev = "1.0";
-      sha256 = "0dlyx1vadppalpc1kr777k8ij3x04lz2m938y205xi7k5ab6j6fr";
-    }}/pinch.py "$@"
-  '';
+  pinch = if builtins.hasAttr "pinch" super then
+    super.pinch
+  else
+    super.writeShellScriptBin "pinch" ''
+      exec ${self.python3}/bin/python3 ${
+        super.fetchgit {
+          url = "https://scottworley.com/pinch.git";
+          rev = "1.3";
+          sha256 = "1l2pq0pqmjh5q8ggmz6sw6bz0nnz0jy92l5qgax8bmpm1qcszmxf";
+        }
+      }/pinch.py "$@"
+    '';
 }