]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/polite-merge.nix
pinch: 3.0.15 → 3.1.0 for "git_ref = tag <tag>" support
[auto-upgrade-with-pinch] / overlays / polite-merge.nix
index e8eda590354669c15f664dfd3f28c3bd06ab078a..37f7ba54aab8f3084c722e26f087291f6d926bfa 100644 (file)
@@ -1,4 +1,10 @@
-self: super: {
+self: super:
+let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+in {
   polite-merge = if builtins.hasAttr "polite-merge" super then
     super.polite-merge
   else
@@ -7,12 +13,12 @@ self: super: {
         pname = "polite-merge";
         version = "2.4";
         src = fetchgit {
-          url = "https://scottworley.com/polite-merge.git";
+          url = "https://git.scottworley.com/pub/git/polite-merge";
           rev = version;
           sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
         };
         postUnpack = "patchShebangs .";
-        checkInputs = [ git ];
+        "${checkInputsName}" = [ git ];
         doCheck = true;
         preInstall = "export prefix";
       }) { };