]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
git-cache: 1.4.2 → 1.4.3
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 420d59461c2d8a35d98eee31cb0d7a05e771c483..7dcddb06546f07b6f91b20c9723bb346b935ebbc 100644 (file)
@@ -1,54 +1,41 @@
 self: super:
 let
-
-  # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
-  fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
-    , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
-    buildPythonPackage rec {
-      pname = "backoff";
-      version = "1.10.0";
-      src = fetchFromGitHub {
-        owner = "litl";
-        repo = pname;
-        rev = "v${version}";
-        sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
-      };
-      format = "pyproject";
-      nativeBuildInputs = [ poetry ];
-      checkInputs = [ pytestCheckHook pytest-asyncio ];
-    }) { };
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
         pname = "git-cache";
-        version = "1.3.1";
+        version = "1.4.3";
         src = fetchgit {
-          url = "https://scottworley.com/git-cache.git";
+          url = "https://git.scottworley.com/pub/git/git-cache";
           rev = "v${version}";
-          sha256 = "0awz7f6avzw9fk9gp1kadj0nbmf1s60qic9zb6ww92zig3khg12k";
+          hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
         };
         propagatedBuildInputs = [ backoff ];
-        checkInputs = [ git mypy ];
+        "${checkInputsName}" = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
-      }) { backoff = self.python3Packages.backoff or fallback-backoff; };
+      }) { };
 
   fallback-pinch = self.python3Packages.callPackage
-    ({ buildPythonPackage, fetchgit, nix, git, makeWrapper, mypy, git-cache, }:
+    ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
       buildPythonPackage rec {
         pname = "pinch";
-        version = "3.0.7";
+        version = "3.0.10";
         src = fetchgit {
-          url = "https://scottworley.com/pinch.git";
+          url = "https://git.scottworley.com/pub/git/pinch";
           rev = "v${version}";
-          sha256 = "sha256-BMESwx3uUVOFekiXr1LSGNF4DXexT26awzIQIzw/iZY=";
+          hash = "sha256-U3TOTfYvM1ONF9DJrWxfhjVQnY7GD96ru6A2Yj01lcg=";
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        checkInputs = [ nix git mypy ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
         postInstall = ''
-          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix}/bin
+          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';
         doCheck = true;
         checkPhase = "./test.sh";