]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
pinch: 3.0.9 → 3.0.10
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 420d59461c2d8a35d98eee31cb0d7a05e771c483..dfb9eaca3b737001867c477c22a10268a2ff1bd7 100644 (file)
@@ -1,54 +1,37 @@
 self: super:
 let
 
-  # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
-  fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
-    , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
-    buildPythonPackage rec {
-      pname = "backoff";
-      version = "1.10.0";
-      src = fetchFromGitHub {
-        owner = "litl";
-        repo = pname;
-        rev = "v${version}";
-        sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
-      };
-      format = "pyproject";
-      nativeBuildInputs = [ poetry ];
-      checkInputs = [ pytestCheckHook pytest-asyncio ];
-    }) { };
-
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
         pname = "git-cache";
-        version = "1.3.1";
+        version = "1.4.2";
         src = fetchgit {
-          url = "https://scottworley.com/git-cache.git";
+          url = "https://git.scottworley.com/pub/git/git-cache";
           rev = "v${version}";
-          sha256 = "0awz7f6avzw9fk9gp1kadj0nbmf1s60qic9zb6ww92zig3khg12k";
+          hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
         };
         propagatedBuildInputs = [ backoff ];
         checkInputs = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
-      }) { backoff = self.python3Packages.backoff or fallback-backoff; };
+      }) { };
 
   fallback-pinch = self.python3Packages.callPackage
-    ({ buildPythonPackage, fetchgit, nix, git, makeWrapper, mypy, git-cache, }:
+    ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
       buildPythonPackage rec {
         pname = "pinch";
-        version = "3.0.7";
+        version = "3.0.10";
         src = fetchgit {
-          url = "https://scottworley.com/pinch.git";
+          url = "https://git.scottworley.com/pub/git/pinch";
           rev = "v${version}";
-          sha256 = "sha256-BMESwx3uUVOFekiXr1LSGNF4DXexT26awzIQIzw/iZY=";
+          hash = "sha256-U3TOTfYvM1ONF9DJrWxfhjVQnY7GD96ru6A2Yj01lcg=";
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        checkInputs = [ nix git mypy ];
+        checkInputs = [ nix_2_3 git mypy ];
         postInstall = ''
-          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix}/bin
+          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';
         doCheck = true;
         checkPhase = "./test.sh";